<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<title>SnowCap hosts pop-up BBQ for clients, donors | Mid-county Memo</title>
			
	<link href='http://fonts.googleapis.com/css?family=Droid+Sans:regular,bold' rel='stylesheet' type='text/css' />
	<link rel="stylesheet" href="https://midcountymemo.com/wp-content/themes/Trim/style.css" type="text/css" media="screen" />
	<link rel="pingback" href="https://midcountymemo.com/xmlrpc.php" />

	<!--[if lt IE 7]>
		<link rel="stylesheet" type="text/css" href="https://midcountymemo.com/wp-content/themes/Trim/css/ie6style.css" />
		<script type="text/javascript" src="https://midcountymemo.com/wp-content/themes/Trim/js/DD_belatedPNG_0.0.8a-min.js"></script>
		<script type="text/javascript">DD_belatedPNG.fix('img#logo, span.overlay, a.zoom-icon, a.more-icon, #menu, #menu-right, #menu-content, ul#top-menu ul, #menu-bar, .footer-widget ul li, span.post-overlay, #content-area, .avatar-overlay, .comment-arrow, .testimonials-item-bottom, #quote, #bottom-shadow, #quote .container');</script>
	<![endif]-->
	<!--[if IE 7]>
		<link rel="stylesheet" type="text/css" href="https://midcountymemo.com/wp-content/themes/Trim/css/ie7style.css" />
	<![endif]-->
	<!--[if IE 8]>
		<link rel="stylesheet" type="text/css" href="https://midcountymemo.com/wp-content/themes/Trim/css/ie8style.css" />
	<![endif]-->
	<!--[if lt IE 9]>
		<script src="https://midcountymemo.com/wp-content/themes/Trim/js/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<title>SnowCap hosts pop-up BBQ for clients, donors | Mid-county Memo</title>

<!-- This site is optimized with the Yoast SEO plugin v7.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="For more than 50 years, SnowCap Community Charities has been feeding and clothing their neighbors in east and mid-Multnomah County, often without anyone"/>
<link rel="canonical" href="https://midcountymemo.com/2018/07/snowcap-hosts-pop-up-bbq-for-clients-donors/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="SnowCap hosts pop-up BBQ for clients, donors | Mid-county Memo" />
<meta property="og:description" content="For more than 50 years, SnowCap Community Charities has been feeding and clothing their neighbors in east and mid-Multnomah County, often without anyone" />
<meta property="og:url" content="https://midcountymemo.com/2018/07/snowcap-hosts-pop-up-bbq-for-clients-donors/" />
<meta property="og:site_name" content="Mid-county Memo" />
<meta property="article:publisher" content="http://www.facebook.com/searchcommander" />
<meta property="article:tag" content="east Portland" />
<meta property="article:tag" content="Kirsten Wageman" />
<meta property="article:tag" content="Marsha Kitchen" />
<meta property="article:tag" content="Oregon Food Bank" />
<meta property="article:tag" content="SnowCap Community Charity" />
<meta property="article:section" content="2018" />
<meta property="article:published_time" content="2018-07-15T09:46:30+00:00" />
<meta property="article:modified_time" content="2018-07-06T13:53:41+00:00" />
<meta property="og:updated_time" content="2018-07-06T13:53:41+00:00" />
<meta property="og:image" content="https://midcountymemo.com/wp-content/uploads/2018/07/YK_SnowCap_BBQ_IMG_5823.jpg" />
<meta property="og:image:secure_url" content="https://midcountymemo.com/wp-content/uploads/2018/07/YK_SnowCap_BBQ_IMG_5823.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="400" />
<meta property="og:image:alt" content="Executive Director Kirsten Wageman leads a pantry tour of SnowCap. STAFF/2018" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="For more than 50 years, SnowCap Community Charities has been feeding and clothing their neighbors in east and mid-Multnomah County, often without anyone" />
<meta name="twitter:title" content="SnowCap hosts pop-up BBQ for clients, donors | Mid-county Memo" />
<meta name="twitter:site" content="@shendison" />
<meta name="twitter:image" content="https://midcountymemo.com/wp-content/uploads/2018/07/YK_SnowCap_BBQ_IMG_5823.jpg" />
<meta name="twitter:creator" content="@shendison" />
<!-- / Yoast SEO plugin. -->

<link rel="amphtml" href="https://midcountymemo.com/2018/07/snowcap-hosts-pop-up-bbq-for-clients-donors/amp/" /><link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//apps.shareaholic.com' />
<link rel='dns-prefetch' href='//grace.shareaholic.com' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="Mid-county Memo &raquo; Feed" href="https://midcountymemo.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mid-county Memo &raquo; Comments Feed" href="https://midcountymemo.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mid-county Memo &raquo; SnowCap hosts pop-up BBQ for clients, donors Comments Feed" href="https://midcountymemo.com/2018/07/snowcap-hosts-pop-up-bbq-for-clients-donors/feed/" />
<!-- This site is powered by Shareaholic - https://shareaholic.com -->
<link rel='preload' href='//apps.shareaholic.com/assets/pub/shareaholic.js' as='script'>
<script type='text/javascript' data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/midcountymemo.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/midcountymemo.com\/wp-admin\/admin-ajax.php","share_counts_url":"https:\/\/midcountymemo.com\/wp-admin\/admin-ajax.php?action=shareaholic_share_counts_api"},"url_components":{"year":"2018","monthnum":"07","day":"15","post_id":"4536","postname":"snowcap-hosts-pop-up-bbq-for-clients-donors","author":"ygal-kaufman"}};
  //]]>
</script>
<script type='text/javascript' data-cfasync='false'
        src='//apps.shareaholic.com/assets/pub/shareaholic.js'
        data-shr-siteid='5d12382e076ca5177a8e6ddc58156c73' async='async' >
</script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='Mid-county Memo' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://midcountymemo.com/2018/07/snowcap-hosts-pop-up-bbq-for-clients-donors/' />
<meta name='shareaholic:keywords' content='east portland, kirsten wageman, marsha kitchen, oregon food bank, snowcap community charity, 2018, july 2018, post' />
<meta name='shareaholic:article_published_time' content='2018-07-15T09:46:30+00:00' />
<meta name='shareaholic:article_modified_time' content='2018-07-06T13:53:41+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Ygal Kaufman' />
<meta name='shareaholic:site_id' content='5d12382e076ca5177a8e6ddc58156c73' />
<meta name='shareaholic:wp_version' content='8.7.2' />
<meta name='shareaholic:image' content='https://midcountymemo.com/wp-content/uploads/2018/07/YK_SnowCap_BBQ_IMG_5823.jpg' />
<!-- Shareaholic Content Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/midcountymemo.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Trim v.2.3.3" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='et-shortcodes-css-css'  href='https://midcountymemo.com/wp-content/themes/Trim/epanel/shortcodes/css/shortcodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='et-shortcodes-responsive-css-css'  href='https://midcountymemo.com/wp-content/themes/Trim/epanel/shortcodes/css/shortcodes_responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='https://midcountymemo.com/wp-content/themes/Trim/epanel/page_templates/js/fancybox/jquery.fancybox-1.3.4.css' type='text/css' media='screen' />
<link rel='stylesheet' id='et_page_templates-css'  href='https://midcountymemo.com/wp-content/themes/Trim/epanel/page_templates/page_templates.css' type='text/css' media='screen' />
<script type='text/javascript' src='https://midcountymemo.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='https://api.w.org/' href='https://midcountymemo.com/wp-json/' />
<link rel='shortlink' href='https://midcountymemo.com/?p=4536' />
<link rel="alternate" type="application/json+oembed" href="https://midcountymemo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmidcountymemo.com%2F2018%2F07%2Fsnowcap-hosts-pop-up-bbq-for-clients-donors%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://midcountymemo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmidcountymemo.com%2F2018%2F07%2Fsnowcap-hosts-pop-up-bbq-for-clients-donors%2F&#038;format=xml" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" /><link id='droid_sans' href='http://fonts.googleapis.com/css?family=Droid+Sans' rel='stylesheet' type='text/css' /><style type='text/css'>body { font-family: 'Droid Sans', Arial, sans-serif !important;  }</style><style type='text/css'>body {  }</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #519eba; }
</style>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-3589332-1', 'auto');
  ga('send', 'pageview');

</script><style type="text/css" id="et-custom-css">
#search-form { display: none; }

#top-area {padding: 22px 49px 144px 58px;}
.blog .featured_box, .archive .featured_box { width: 200px; height: auto; float: left; margin-right: 8px; }
#top-area {padding: 22px 49px 144px 58px;}
.blog .featured_box, .archive .featured_box { width: 100%; height: auto; float: left; margin-right: 8px; }
#top-area, #featured_controls, #featured-controllers, #services, #quote, #home-sections, #menu { border-bottom: 1px solid #519eba; }
#search-form, #commentform input[type="text"], #commentform textarea, blockquote { border:1px solid #519eba; }
#featured-controllers li, #comment-wrap:before, #respond:before { border-top:1px solid #519eba; }
#home-sections:before, #main_content:before { border-left: 1px dashed #519eba; }
#menu .nav li, #featured-controllers li, .footer-widget { border-right: 1px dashed #519eba; }
#mobile_nav { border: 1px dashed #519eba; }
#menu .nav a, ul#mobile_menu a, p.meta, p.meta a { color: #519eba; }
#breadcrumbs span, #breadcrumbs a { color: #519eba; }
#main_content:before { left: 619px; }
@media only screen and ( min-width: 768px ) and ( max-width: 960px ) {
#main_content:before { left: 492px; }
}
@media only screen and ( max-width: 767px ) {
#top-area { padding-bottom: 0; }
}

ul#mobile_menu a {
color: #fff !important;
}

.featured_box img { width: 481px!important; height: auto!important; }
#content { font-size: 18px; }
</style></head>
<body class="post-template-default single single-post postid-4536 single-format-standard custom-background unknown et_includes_sidebar">
	<div id="container">
		<div id="wrapper">
			<header id="main-header" class="clearfix">
				<div id="top-area">
										<a href="https://midcountymemo.com/">
												<img src="https://midcountymemo.com/wp-content/uploads/2018/07/mcm_july2018_hdr.jpg" alt="Mid-county Memo" id="logo"/>
					</a>
					<div id="search-form">
						<form method="get" id="searchform" action="https://midcountymemo.com//">
							<input type="text" value="Search..." name="s" id="searchinput" />
							<input type="image" alt="Submit" src="https://midcountymemo.com/wp-content/themes/Trim/images/search_btn.png" id="searchsubmit" />
						</form>
					</div> <!-- end #search-form -->
				</div> <!-- end #top-area -->

				<div id="menu" class="clearfix">
					<a href="#" id="mobile_nav" class="closed">Navigation Menu</a>
					<nav id="main-menu">
						<ul id="menu-full-menu" class="nav"><li id="menu-item-32" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-32"><a href="https://midcountymemo.com/">Home</a></li>
<li id="menu-item-196" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-196"><a>About</a>
<ul class="sub-menu">
	<li id="menu-item-33" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33"><a href="https://midcountymemo.com/about-the-memo/">Our Paper</a></li>
	<li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://midcountymemo.com/staff/">Our Staff</a></li>
</ul>
</li>
<li id="menu-item-164" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164"><a>Departments</a>
<ul class="sub-menu">
	<li id="menu-item-81" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://midcountymemo.com/category/calendar/">Calendar</a></li>
	<li id="menu-item-83" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="https://midcountymemo.com/category/memo-pad/">Memo Pad</a></li>
	<li id="menu-item-89" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89"><a href="https://midcountymemo.com/category/business-memos/">Business Memos</a></li>
	<li id="menu-item-90" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90"><a href="https://midcountymemo.com/category/letters/">Letters</a></li>
	<li id="menu-item-82" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a href="https://midcountymemo.com/category/meals-on-wheels/">Meals on Wheels</a></li>
	<li id="menu-item-161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-161"><a href="https://midcountymemo.com/category/mid-county-restaurant-ratings/">Mid-county Restaurant Ratings</a></li>
	<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://midcountymemo.com/category/lottery/">Oregon Lottery in Mid-county</a></li>
	<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://midcountymemo.com/category/parkrose-athletic/">Parkrose Athletic Schedule</a></li>
</ul>
</li>
<li id="menu-item-197" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-197"><a>Advertising</a>
<ul class="sub-menu">
	<li id="menu-item-34" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34"><a href="https://midcountymemo.com/advertise/">Print &#038; Web Rates</a></li>
	<li id="menu-item-36" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36"><a href="https://midcountymemo.com/coverage-areas/">Coverage Areas</a></li>
</ul>
</li>
<li id="menu-item-191" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-191"><a href="/about/">Contact</a></li>
</ul>					</nav>

					<div id="social-icons">
						<a href='https://twitter.com/midcountymemo' target='_blank'><img alt='Twitter' src='https://midcountymemo.com/wp-content/themes/Trim/images/twitter.png' /></a><a href='/feed/' target='_blank'><img alt='Rss' src='https://midcountymemo.com/wp-content/themes/Trim/images/rss.png' /></a><a href='https://www.facebook.com/midcountymemo' target='_blank'><img alt='Facebook' src='https://midcountymemo.com/wp-content/themes/Trim/images/facebook.png' /></a>					</div> <!-- end #social-icons -->
				</div> <!-- end #menu -->
			</header> <!-- end #main-header -->

			<div id="content">
<div id="main_content" class="clearfix">
	<div id="left_area">
		<div id="breadcrumbs">
					<a href="https://midcountymemo.com/">Home</a> <span class="raquo">&raquo;</span>

									<a href="https://midcountymemo.com/category/2018/">2018</a> <span class="raquo">&raquo;</span> SnowCap hosts pop-up BBQ for clients, donors					</div> <!-- end #breadcrumbs -->			
	<article class="entry post clearfix">
					<span class="post-meta">Sun<span>15</span></span>
		
		<h1 class="main_title">SnowCap hosts pop-up BBQ for clients, donors</h1>

		<p class="meta">Posted  by <a href="https://midcountymemo.com/author/ygal-kaufman/" title="Posts by Ygal Kaufman" rel="author">Ygal Kaufman</a> on Jul 15, 2018</p>
		<div class="post-content clearfix">
						
			<div class="entry_content">
				<div class='shareaholic-canvas' data-app='share_buttons' data-title='SnowCap hosts pop-up BBQ for clients, donors' data-link='https://midcountymemo.com/2018/07/snowcap-hosts-pop-up-bbq-for-clients-donors/' data-app-id='7898751' data-app-id-name='post_above_content'></div><div id="attachment_4504" style="width: 310px" class="wp-caption alignright"><a href="https://midcountymemo.com/wp-content/uploads/2018/07/YK_SnowCap_BBQ_IMG_5823.jpg"><img class="size-medium wp-image-4504" src="https://midcountymemo.com/wp-content/uploads/2018/07/YK_SnowCap_BBQ_IMG_5823-300x200.jpg" alt="Executive Director Kirsten Wageman leads a pantry tour of SnowCap. STAFF/2018" width="300" height="200" srcset="https://midcountymemo.com/wp-content/uploads/2018/07/YK_SnowCap_BBQ_IMG_5823-300x200.jpg 300w, https://midcountymemo.com/wp-content/uploads/2018/07/YK_SnowCap_BBQ_IMG_5823-150x100.jpg 150w, https://midcountymemo.com/wp-content/uploads/2018/07/YK_SnowCap_BBQ_IMG_5823-140x94.jpg 140w, https://midcountymemo.com/wp-content/uploads/2018/07/YK_SnowCap_BBQ_IMG_5823.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" /></a><p class="wp-caption-text">Executive Director Kirsten Wageman leads a pantry tour of SnowCap.<br />STAFF/2018</p></div>
<p>For more than 50 years, SnowCap Community Charities has been feeding and clothing their neighbors in east and mid-Multnomah County, often without anyone even noticing or being aware of their existence. They took a step to change that on a cloudy Friday afternoon this past month, holding a pop-up barbecue to thank their volunteers and donors as well as treat their normal clientele to a social event.</p>
<p>The cookout was attended by a healthy crowd representing a broad cross-section of the different types of stakeholders involved in the charity. There was a buffet with meat and veggie burgers, as well as hot dogs, all the fixings one could hope for, fresh fruit, baked goods and other treats. SnowCap staff and volunteers were working the grill, handing out food and enjoying the day with the clients seated in the garden. In addition to housing their robust food and clothing services, SnowCap also has an overflowing community garden tended by their clients.</p>
<p>SnowCap achieved the successful turnout for this event largely through the same methods with which they’ve thrived for over half a century: word of mouth and a great reputation. “We are the largest distributor of food assistance in the state of Oregon. We’re founding members of the Oregon Food Bank, so we’ve been serving Multnomah County since 1967,” says Kirsten Wageman, SnowCap’s executive director. The group sprouted from church groups and was one of many Community Action Programs (CAPs) that were a joint strategy for charitable giving and community rehabilitation in the 1960s and 1970s. While nearly all the other CAPs have folded or merged with other organizations, SnowCap continues and now boasts nine full-time staff members and more than a thousand volunteers. “If it happens here, a volunteer probably did it. With only nine of us on staff, it would be impossible [to do all the work on our own],” says Wageman.</p>
<p>SnowCap barely has to advertise its presence or events. Wageman says she doesn’t even know how people know about it to come for help. “We’re not sure, but they all make it here, “says Wageman. “The Oregon Food Bank lists us as a resource; we’re sort of like their model pantry.”</p>
<p>SnowCap has a unique system wherein clients are free to come once a month and collect three to five days’ worth of food, plus clothing and often toiletries and other sundry goods. Further setting apart their system is that the clients can come and “shop” for goods in a pantry that resembles a supermarket. This focus on freedom and dignity for the clients is one of the things that make the charity so long-standing and beloved by the people who support it.</p>
<p>Marsha Kitchen was one of the many donors who dropped by to have something to eat and see the fruits of their charitable donations. “We became acquainted with the organization through church, and we love how they work,” says Kitchen. “They’re just so responsive. And they’re good stewards of all that they have, and that means a lot to my husband and me. It’s been a good partnership.”</p>
<p>At the barbecue, there were also boxes prepared with special items, toiletries and other non-food necessities. There was also a cart full of tomato and sweet potato vegetable starts, which were given away to anyone wanting to grow some food at home. While these other items were featured today, food and clothing are really the mainstays that SnowCap works with. “We stay laser-focused on those two things, because we feel like we do a good job,” says Wageman, who was flanked by her young daughter and a host of friends as she ate, laughed and led tours of the facilities for the many donors, like Marsha Kitchen, who had never even seen the operation up close, despite providing years of financial support.</p>
<p>Rounding out the colorful assortment of Portlanders enjoying the day were the firemen and the mermaids. A local unit and their truck represented Portland Fire Bureau, which was a hit with many of the children and seniors present. Meanwhile, holding court in the garden was Grandmer Orchid and Yl’luria Watersong, who were hanging out, posing for pictures and entertaining both young and old. The two are part of Portland’s bustling mermaid performance art scene and donated their time to SnowCap for the day.</p>
<p>Currently, food and clothing donations, as well as support from donors and volunteers, is very strong, and SnowCap is always accepting new clients. “Anyone who lives east of 82nd Avenue and within Multnomah County is welcome to come once a month,” says Wageman. “We’re a very stable organization; we’re not always doing the newest thing, but we’re always providing food, and we’ve never had to shut our doors from running out.”</p>
<p>SnowCap is at 17805 S.E. Stark St. behind the Rockwood Center. You can reach them by phone at 503-674-8785 and by email at <a href="mailto:info@snowcap.com">info@snowcap.com</a>. Donations are accepted at 17788 S.E. Pine St.<span class="Apple-converted-space">  </span></p>
<div class='shareaholic-canvas' data-app='share_buttons' data-title='SnowCap hosts pop-up BBQ for clients, donors' data-link='https://midcountymemo.com/2018/07/snowcap-hosts-pop-up-bbq-for-clients-donors/' data-app-id='7898747' data-app-id-name='post_below_content'></div>											</div> <!-- end .entry_content -->
		</div> <!-- end .post-content -->
	</article> <!-- end .post -->

	
	
	<!-- You can start editing here. -->

<section id="comment-wrap">
		   <div id="comment-section" class="nocomments">
		  			 <!-- If comments are open, but there are no comments. -->

		  	   </div>
					<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Post a Reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/07/snowcap-hosts-pop-up-bbq-for-clients-donors/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://midcountymemo.com/wp-comments-post.php?wpe-comment-post=memosite" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='4536' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3c41ef2894" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="187"/></p>			</form>
			</div><!-- #respond -->
		
</section>	</div> <!-- end #left_area -->

		<div id="sidebar">
		<div id="archives-2" class="widget widget_archive"><h4 class="widget_title">Previous Issues</h4>		<label class="screen-reader-text" for="archives-dropdown-2">Previous Issues</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://midcountymemo.com/2018/07/'> July 2018 </option>
	<option value='https://midcountymemo.com/2018/06/'> June 2018 </option>
	<option value='https://midcountymemo.com/2018/05/'> May 2018 </option>
	<option value='https://midcountymemo.com/2018/04/'> April 2018 </option>
	<option value='https://midcountymemo.com/2018/03/'> March 2018 </option>
	<option value='https://midcountymemo.com/2018/02/'> February 2018 </option>
	<option value='https://midcountymemo.com/2018/01/'> January 2018 </option>
	<option value='https://midcountymemo.com/2017/12/'> December 2017 </option>
	<option value='https://midcountymemo.com/2017/11/'> November 2017 </option>
	<option value='https://midcountymemo.com/2017/10/'> October 2017 </option>
	<option value='https://midcountymemo.com/2017/09/'> September 2017 </option>
	<option value='https://midcountymemo.com/2017/08/'> August 2017 </option>
	<option value='https://midcountymemo.com/2017/07/'> July 2017 </option>
	<option value='https://midcountymemo.com/2017/06/'> June 2017 </option>
	<option value='https://midcountymemo.com/2017/05/'> May 2017 </option>
	<option value='https://midcountymemo.com/2017/04/'> April 2017 </option>
	<option value='https://midcountymemo.com/2017/03/'> March 2017 </option>
	<option value='https://midcountymemo.com/2017/02/'> February 2017 </option>
	<option value='https://midcountymemo.com/2017/01/'> January 2017 </option>
	<option value='https://midcountymemo.com/2016/12/'> December 2016 </option>
	<option value='https://midcountymemo.com/2016/11/'> November 2016 </option>
	<option value='https://midcountymemo.com/2016/10/'> October 2016 </option>
	<option value='https://midcountymemo.com/2016/09/'> September 2016 </option>
	<option value='https://midcountymemo.com/2016/08/'> August 2016 </option>
	<option value='https://midcountymemo.com/2016/07/'> July 2016 </option>
	<option value='https://midcountymemo.com/2016/06/'> June 2016 </option>
	<option value='https://midcountymemo.com/2016/05/'> May 2016 </option>
	<option value='https://midcountymemo.com/2016/04/'> April 2016 </option>
	<option value='https://midcountymemo.com/2016/03/'> March 2016 </option>
	<option value='https://midcountymemo.com/2016/02/'> February 2016 </option>
	<option value='https://midcountymemo.com/2016/01/'> January 2016 </option>
	<option value='https://midcountymemo.com/2015/12/'> December 2015 </option>
	<option value='https://midcountymemo.com/2015/11/'> November 2015 </option>
	<option value='https://midcountymemo.com/2015/10/'> October 2015 </option>
	<option value='https://midcountymemo.com/2015/09/'> September 2015 </option>
	<option value='https://midcountymemo.com/2015/08/'> August 2015 </option>
	<option value='https://midcountymemo.com/2015/07/'> July 2015 </option>
	<option value='https://midcountymemo.com/2015/06/'> June 2015 </option>
	<option value='https://midcountymemo.com/2015/05/'> May 2015 </option>
	<option value='https://midcountymemo.com/2015/04/'> April 2015 </option>
	<option value='https://midcountymemo.com/2015/03/'> March 2015 </option>
	<option value='https://midcountymemo.com/2015/02/'> February 2015 </option>
	<option value='https://midcountymemo.com/2015/01/'> January 2015 </option>
	<option value='https://midcountymemo.com/2014/12/'> December 2014 </option>
	<option value='https://midcountymemo.com/2014/11/'> November 2014 </option>
	<option value='https://midcountymemo.com/2014/10/'> October 2014 </option>
	<option value='https://midcountymemo.com/2014/09/'> September 2014 </option>
	<option value='https://midcountymemo.com/2014/08/'> August 2014 </option>

		</select>
		</div> <!-- end .widget --><div id="text-10" class="widget widget_text"><h4 class="widget_title">Newspaper Morgue </h4>			<div class="textwidget"><a href=" https://midcountymemo.com/archives/">August 2001 to August 2014</a></div>
		</div> <!-- end .widget --><div id="text-11" class="widget widget_text"><h4 class="widget_title"> </h4>			<div class="textwidget"><div align="center"><a href="http://www.oregonlive.com/onn" target="_blank" rel="noopener"><img src="https://midcountymemo.com/memlog/wp-content/uploads/ONN_logo_text_186.jpg" alt="Oregonian News Network" border="0" /></a><a href="http://www.spj.org/" target="_blank" rel="noopener"><img src="/wp-content/uploads/download-1-e1412035243262.jpg" alt="Oregonian News Network" border="0" /></a></p>
</div>
</div>
		</div> <!-- end .widget --><div id="text-5" class="widget widget_text"><h4 class="widget_title"> </h4>			<div class="textwidget"><div align="center">
<a href="http://www.cityhomeimprovementinc.com/" target="_blank"><img src="https://midcountymemo.com/images/city_home_ani_new.gif" alt="City Home Improvement" /></a>

<a href="http://www.tirefactory.com/parkrose" target="_blank"><img src="https://midcountymemo.com/wp-content/uploads/83587_Browns699_2016.05.06_Mid-County-Memo-Banner-Ad_120x240.jpg" alt="Brown Tire Factory" /></a>

<a href="http://www.eatatelmers.com/" target="_blank"><img src="https://midcountymemo.com/images/elmers_ani_new.gif" alt="Elmer's Restaurant" /></a> <br>

<a href="http://www.fortknoxmini-storage.com" target="_blank"><img src="https://midcountymemo.com/images/fort_knox_banner.jpg" alt="Fort Knox Mini Storage" /></a> <br>

<a href="http://www.gosolarparkrose.com" target="_blank"><img src="https://midcountymemo.com/wp-content/uploads/2017/03/SES_web_ad.jpg" alt="Solar Energy Solutions" /></a> <br>


</div></div>
		</div> <!-- end .widget --><div id="search-3" class="widget widget_search"><h4 class="widget_title"> </h4><form role="search" method="get" id="searchform" class="searchform" action="https://midcountymemo.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div> <!-- end .widget --><div id="text-8" class="widget widget_text"><h4 class="widget_title"> </h4>			<div class="textwidget"><div align="center">
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fmidcountymemo&amp;width=235&amp;height=258&amp;colorscheme=light&amp;show_faces=true&amp;border_color&amp;stream=false&amp;header=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:100%; height:258px;" allowTransparency="true"></iframe>
</div>
<br>
<a href="/wp-admin" target="_blank"  rel="nofollow">Editor log-In</a></div>
		</div> <!-- end .widget -->	</div> <!-- end #sidebar -->
</div> <!-- end #main_content -->

				<div id="footer">

					<div id="footer-widgets" class="clearfix">

						<div class="footer-widget"><div id="rss-14" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.publicalerts.org/rss.xml' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='https://www.publicalerts.org/latest-alerts?' target='_blank' title=''>Public Alerts</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://twitter.com/PDXFire/status/1018973023892721665' target='_blank' title='E Burnside St fire: Fire is out. Crews checking for extensions. #alert'>E Burnside St fire: Fire is out. Crews checking for extensions. #alert</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://twitter.com/PDXFire/status/1018971680549494784' target='_blank' title='PF&amp;R is now responding to a second, simultaneous fire (Residential Structure) at 10737 E Burnside St. #alert'>PF&amp;amp;R is now responding to a second, simultaneous fire (Residential Structure) at 10737 E Burnside St. #alert</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://twitter.com/PDXFire/status/1018970564805865472' target='_blank' title='SE MLK &amp; Ash fire: Investigator is on scene to assist in determining cause. #alert'>SE MLK &amp;amp; Ash fire: Investigator is on scene to assist in determining cause. #alert</a></li></ul></div> <!-- end .f_widget --><div id="rss-10" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.google.com/calendar/feeds/parkrose.k12.or.us_15j6km0ui85kplddm9mqadgi8c%40group.calendar.google.com/public/basic' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='' target='_blank' title=''>Parkrose School District</a></h4></div> <!-- end .f_widget --><div id="rss-3" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.ddouglas.k12.or.us/feed/' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='https://www.ddouglas.k12.or.us' target='_blank' title='Learning Today for Living Tomorrow'>David Douglas School District</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://www.ddouglas.k12.or.us/2018/06/free-summer-meals-for-kids-2018/' target='_blank' title='Free breakfasts and lunches for all children 18 and under are available this summer at multiple sites in the David Douglas community (no registration needed). There are no services on July 4th. Floyd Light Middle School – 10800 SE Washington Street July 9th-August 2nd Monday-Thursday Breakfast: 9-9:30am Lunch: 12:30-1pm West Powellhurst –…  Read More about Free Summer Meals For Kids The post Free Summer Meals For Kids appeared first on David Douglas School District. '>Free Summer Meals For Kids</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://www.ddouglas.k12.or.us/2018/06/2018-graduation-videos/' target='_blank' title='Watch the graduation ceremonies for DDHS and FRC via the links below. Fir Ridge Campus held their commencement on Friday, June 1st. 79 students graduated. View FRC ceremony David Douglas High School held their commencement on Wednesday, June 6th. 555 students graduated. View DDHS ceremony   Congratulations class of 2018, we’re proud…  Read More about 2018 Graduation Videos The post 2018 Graduation Videos appeared first on David Douglas School District. '>2018 Graduation Videos</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://www.ddouglas.k12.or.us/2018/06/register-for-kindergarten-2018-19/' target='_blank' title='Children who are 5 years old by September 1st, start kindergarten this fall. Before schools close for the summer, complete registration at your neighborhood school to give your child a good start, connect to summer activities, and obtain access to free resources. The last day most elementary schools are open is Friday,…  Read More about Register for Kindergarten 2018-19 The post Register for Kindergarten 2018-19 appeared first on David Douglas School District. '>Register for Kindergarten 2018-19</a></li></ul></div> <!-- end .f_widget --><div id="rss-15" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.trimet.org/rss/index.htm#alerts' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='' target='_blank' title=''>TriMet Service Alerts</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --><div id="rss-8" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://feeds.feedburner.com/rsd7?' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='' target='_blank' title=''>Reynolds School District</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --><div id="rss-18" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=49305' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=49305' target='_blank' title=''>Portland Parks &#038; Recreation</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --></div><div class="footer-widget"><div id="rss-21" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=36652' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=36652' target='_blank' title='Downtown, Arlington Heights, Forest Park, Goosehollow, Hillside, Linnton, Northwest District, Northwest Heights, Northwest Industrial, Pearl District and Sylvan-Highlands '>City Land Use Notices, Hearings and Decisions</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=46575&#038;a=691250' target='_blank' title='PDF Document, 2,205kbCategory: Neighbors West/Northwest Decisions'>Pearl District | 07-16-18 | 417-419 NW 9th Ave | Design Review | LU 18-181403 DZ</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=46576&#038;a=691249' target='_blank' title='PDF Document, 1,315kbCategory: Northeast Coalition of Neighbors Decisions'>Sullivan&#039;s Gulch | 07-16-18 | 1532 NE Broadway | Adjustment Review | LU 18-181172 AD</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=42259&#038;a=691248' target='_blank' title='PDF Document, 1,489kbCategory: Neighbors West/Northwest'>Portland Downtown | 07-16-18 | 819 SW Oak St | Design Review - NOTICE | LU 18-193936 DZ</a></li></ul></div> <!-- end .f_widget --><div id="rss-20" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=61875' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=61875' target='_blank' title='Application materials for new licensees'>City of Portland New Liquor License Applications</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=61875&#038;a=630656' target='_blank' title='PDF Document, 955kbCategory: New Liquor License Applications'>Liquor Licensing Forms and Checklist</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=61875&#038;a=580926' target='_blank' title='This link only provides the form to fill our personal history of each applicant. PDF Document, 213kbCategory: New Liquor License Applications'>Personal History Form</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=61875&#038;a=580925' target='_blank' title='This link only provides the form to provide outlet information. PDF Document, 332kbCategory: New Liquor License Applications'>Outlet Information Form</a></li></ul></div> <!-- end .f_widget --><div id="rss-12" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=25783' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=25783' target='_blank' title='Southeast Uplift Neighborhood Coalition'>City of Portland</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=69018&#038;a=691316' target='_blank' title='2534 SE BELMONT ST - COMMENTS DUE 8-16-18 PDF Document, 294kbCategory: Inner Southeast Portland (SEUL)'>KALA NOODLE AND GRILL</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=73367&#038;a=691307' target='_blank' title='PDF Document, 47kbCategory: Calendar'>July 2 - July 8, 2018 Eudaly Calendar</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=73367&#038;a=691306' target='_blank' title='PDF Document, 46kbCategory: Calendar'>June 25 - July 1, 2018 Eudaly Calendar</a></li></ul></div> <!-- end .f_widget --><div id="rss-11" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=29795' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=29795' target='_blank' title=''>Portland Police Bureau</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --><div id="rss-17" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.flashalert.net/news.html?id=549#news78560' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='' target='_blank' title=''>Portland Fire &#038; Rescue</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --></div><div class="footer-widget last"><div id="rss-16" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.flashalert.net/news.html?id=1276' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='' target='_blank' title=''>Multnomah County Sheriff&#8217;s Office</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --><div id="rss-13" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=48714' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=48714' target='_blank' title='Woodland Park'>East Portland Neighborhood Offices</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=48684&#038;a=491293' target='_blank' title='Find information such as area parks, schools, planned projects, zoning information, aerial maps and much more on PortlandMaps.com'>PortlandMaps.com link for Woodland Park neighborhood</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=48684&#038;a=491291' target='_blank' title='Link to Bureau of Planning and Sustainability&#039;s District Planning Program'>District Liaison Planning Program</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=48684&#038;a=491289' target='_blank' title='Link to Prosper Portland&#039;s Website with information about geographically based development programs'>Prosper Portland&#039;s Urban Renewal and Development Programs</a></li></ul></div> <!-- end .f_widget --><div id="rss-9" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://eastportlandchamberofcommerce.com/Month-at-a-Glance/RSS' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='https://eastportlandchamberofcommerce.com/Month-at-a-Glance' target='_blank' title='East Portland Chamber of Commerce upcoming events'>East Portland Chamber of Commerce</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://eastportlandchamberofcommerce.com/event-2754779' target='_blank' title='  Leveraging Your Chamber Membership with Gary Russell, EPCC President  The East Portland Chamber of Commerce is kicking off the new year with an event specifically designed to help you to make the most of your membership in 2018. In order to do so, you need to decide what is most important to you and your business. Gary Russell, EPCC&#039;s 2018 President and owner of Defend My Life, will teach you how to:     Identify your objectives    Determine your involvement contribution    Learn your currency: business is the equitable exchange of resources     Make the most out of meetings outside of the meeting     Coffee and breakfast goodies will be provided.  Coffee and meeting space sponsored by:  '>Leveraging Your Chamber Membership 1-3-18 (January 03, 2018)</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://eastportlandchamberofcommerce.com/event-2427287' target='_blank' title='  Join us for a casual night of fun with fellow chamber members and guests. You&#039;ll get a chance to see some of our members who are not able to make morning meetings. Please invite employees, friends, family and potential new Chamber members. 21 and over only. The Chamber provides FREE appetizers!               '>Chamber Happy Hour 1-4-18 (January 04, 2018)</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://eastportlandchamberofcommerce.com/event-2182664' target='_blank' title='The Ambassadors Committee meets the 2nd Monday of every month at Old Chicago Pizza. Ambassadors greet members and guests at the AM meetings, assist with special events, attend ribbon cutting ceremonies at grand openings, and help create fun new ways for Chamber members to interact with each other. This is an excellent way to get to know your fellow Chamber members and help your East Portland Chamber!'>Committee Meeting: Ambassadors (January 08, 2018)</a></li></ul></div> <!-- end .f_widget --><div id="rss-7" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://parkrosebusiness.org/feed/' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://parkrosebusiness.org' target='_blank' title='PBA provides a unified voice to City of Portland officials on behalf of the Parkrose business community'>Parkrose Business Association</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://parkrosebusiness.org/2017/11/06/november-newsletter/' title='PBA November Newsletter Monthly Member Luncheon Gets Delicious New Digs Thursday, 11/16 11:30-1:00 Hello Parkrose! We are thrilled to announce that our Member Luncheon has a new home—Elmer’s Restaurant on Sandy! What’s more, thanks to a new grant from Venture Portland, from now until June 2018, lunch will only costRead More'>November Newsletter</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://parkrosebusiness.org/2017/11/03/parkrose-trunk-or-treat-was-spooktacularly-successful/' title='The Parkrose High School parking lot played host to a horrifying display of paranormal activity on last Sunday. Over 2,000 small but terrifying apparitions descended upon 23 local businesses who bravely held them off with over 50,000 pieces of candy. Argay Square, Brown’s Point S Tire, Central Northeast Neighbors, Century Associates,Read More'>Parkrose Trunk or Treat was Spooktacularly Successful!</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://parkrosebusiness.org/2017/02/28/crime-reporting-tool-kit-2/' title='The Parkrose Business Association is committed to creating a safe environment for our local businesses. Download our crime reporting tool kit to find the best resource to report vandalism, theft, or other suspicious activity. Download: Parkrose Crime Reporting Tool KitRead More'>Crime Reporting Tool Kit</a></li></ul></div> <!-- end .f_widget --><div id="rss-19" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.oregonmetro.gov/news.xml' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='https://www.oregonmetro.gov/news/archive?topic=All&#038;&#038;created%5Bvalue%5D&#038;councilor=&#038;project=All&#038;search_keys=&#038;sort_by=created&#038;sort_order=DESC' target='_blank' title=''>Metro</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://www.oregonmetro.gov/news/council-consider-proposed-food-scraps-policy-thursday' target='_blank' title='By Rebecca KoffmanBylined articles are written by Metro writers and do not necessarily represent the opinions of Metro or the Metro Council. Learn more         On Thursday, July 19, the Metro Council will consider a proposed ordinance that requires the collection of food scraps from certain types of food service businesses. After the policy is proposed, the Council will open the meeting for testimony from the public.   '>Council to consider proposed food scraps policy Thursday</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://www.oregonmetro.gov/news/new-report-details-barriers-diversifying-construction-workforce-offers-recommendations' target='_blank' title='By Cristina RojasBylined articles are written by Metro staff and do not necessarily represent the opinions of Metro or the Metro Council. Learn more          A study was commissioned to uncover the region&#039;s major barriers to achieving equity and increasing diversity in the construction workforce   '>New report details barriers to diversifying construction workforce, offers recommendations</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://www.oregonmetro.gov/news/glean-artists-work-through-weight-waste' target='_blank' title='By Megan Zabel HolmesBylined articles are written by Metro staff and do not necessarily represent the opinions of Metro or the Metro Council. Learn more          Art created from items gleaned at the Metro Central transfer station will be on display in Northeast Portland starting Aug. 3.   '>GLEAN artists work through the weight of waste</a></li></ul></div> <!-- end .f_widget --></div>
					</div> <!-- end #footer-widgets -->

				</div> <!-- end #footer -->

			</div> <!-- end #content -->

		</div> <!-- end #wrapper -->



		<p id="copyright">Designed by <a href="http://www.getwpress.com" target="_blank" title="Get WPress">GetWPress</a> | Powered by <a href="https://www.searchcommander.com" target="_blank">Search Commander, Inc.</a></p>
	</div> <!-- end #container -->



	<!-- Facebook Pixel Code -->



<!-- ConnectRetarget PowerPixel -->
<script>
var CRConfig = {
    'pixel_prefix':'searchcommanderconnectio',
    'init_fb':true,
    'fb_pixel_id':'313786535445179'
};
</script>
<script src='//connectio.s3.amazonaws.com/connect-retarget.js?v=1.1'></script>
<noscript><img height='1' width='1' style='display:none' src='https://www.facebook.com/tr?id=313786535445179&ev=PageView&noscript=1' /></noscript>
<!-- End ConnectRetarget PowerPixel -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '382320112160402'); // Insert your pixel ID here.
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=382320112160402&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code --><script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/js/superfish.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/js/jquery.easing.1.3.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/js/jquery.flexslider-min.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/js/custom.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/epanel/page_templates/js/fancybox/jquery.fancybox-1.3.4.pack.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var et_ptemplates_strings = {"captcha":"Captcha","fill":"Fill","field":"field","invalid":"Invalid email"};
/* ]]> */
</script>
<script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/epanel/page_templates/js/et-ptemplates-frontend.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://midcountymemo.com/wp-content/plugins/akismet/_inc/form.js'></script>

</body>

</html>

