<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<title>82nd Avenue looks at life after 82nd Avenue of Roses Implementation Plan | Mid-county Memo</title>
			
	<link href='http://fonts.googleapis.com/css?family=Droid+Sans:regular,bold' rel='stylesheet' type='text/css' />
	<link rel="stylesheet" href="https://midcountymemo.com/wp-content/themes/Trim/style.css" type="text/css" media="screen" />
	<link rel="pingback" href="https://midcountymemo.com/xmlrpc.php" />

	<!--[if lt IE 7]>
		<link rel="stylesheet" type="text/css" href="https://midcountymemo.com/wp-content/themes/Trim/css/ie6style.css" />
		<script type="text/javascript" src="https://midcountymemo.com/wp-content/themes/Trim/js/DD_belatedPNG_0.0.8a-min.js"></script>
		<script type="text/javascript">DD_belatedPNG.fix('img#logo, span.overlay, a.zoom-icon, a.more-icon, #menu, #menu-right, #menu-content, ul#top-menu ul, #menu-bar, .footer-widget ul li, span.post-overlay, #content-area, .avatar-overlay, .comment-arrow, .testimonials-item-bottom, #quote, #bottom-shadow, #quote .container');</script>
	<![endif]-->
	<!--[if IE 7]>
		<link rel="stylesheet" type="text/css" href="https://midcountymemo.com/wp-content/themes/Trim/css/ie7style.css" />
	<![endif]-->
	<!--[if IE 8]>
		<link rel="stylesheet" type="text/css" href="https://midcountymemo.com/wp-content/themes/Trim/css/ie8style.css" />
	<![endif]-->
	<!--[if lt IE 9]>
		<script src="https://midcountymemo.com/wp-content/themes/Trim/js/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<title>82nd Avenue looks at life after 82nd Avenue of Roses Implementation Plan | Mid-county Memo</title>

<!-- This site is optimized with the Yoast SEO plugin v5.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="82nd Avenue is the spine that connects east and west Portland. The 82nd Avenue of Roses Implementation Plan, as the Mid-county Memo previously reported, is"/>
<meta name="keywords" content="82nd Avenue, 82nd Avenue of Roses Implementation Plan, Terra Lingley, Oregon Department of Transportation, east Portland"/>
<link rel="canonical" href="https://midcountymemo.com/2017/10/82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="82nd Avenue looks at life after 82nd Avenue of Roses Implementation Plan | Mid-county Memo" />
<meta property="og:description" content="82nd Avenue is the spine that connects east and west Portland. The 82nd Avenue of Roses Implementation Plan, as the Mid-county Memo previously reported, is" />
<meta property="og:url" content="https://midcountymemo.com/2017/10/82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan/" />
<meta property="og:site_name" content="Mid-county Memo" />
<meta property="article:publisher" content="http://www.facebook.com/searchcommander" />
<meta property="article:tag" content="82nd Avenue of Roses Implementation Plan" />
<meta property="article:tag" content="82nd Avenue." />
<meta property="article:tag" content="east Portland" />
<meta property="article:tag" content="Oregon Department of Transportation" />
<meta property="article:tag" content="Terra Lingley" />
<meta property="article:section" content="2017" />
<meta property="article:published_time" content="2017-10-28T12:42:49+00:00" />
<meta property="article:modified_time" content="2017-10-05T22:41:23+00:00" />
<meta property="og:updated_time" content="2017-10-05T22:41:23+00:00" />
<meta property="og:image" content="https://fbcdn-profile-a.akamaihd.net/hprofile-ak-frc1/s148x148/432322_318058314919493_1789062476_a.jpg" />
<meta property="og:image:secure_url" content="https://fbcdn-profile-a.akamaihd.net/hprofile-ak-frc1/s148x148/432322_318058314919493_1789062476_a.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="82nd Avenue is the spine that connects east and west Portland. The 82nd Avenue of Roses Implementation Plan, as the Mid-county Memo previously reported, is" />
<meta name="twitter:title" content="82nd Avenue looks at life after 82nd Avenue of Roses Implementation Plan | Mid-county Memo" />
<meta name="twitter:site" content="@shendison" />
<meta name="twitter:image" content="https://fbcdn-profile-a.akamaihd.net/hprofile-ak-frc1/s148x148/432322_318058314919493_1789062476_a.jpg" />
<meta name="twitter:creator" content="@shendison" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/midcountymemo.com\/","name":"Mid-county Memo","potentialAction":{"@type":"SearchAction","target":"https:\/\/midcountymemo.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mid-county Memo &raquo; Feed" href="https://midcountymemo.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mid-county Memo &raquo; Comments Feed" href="https://midcountymemo.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mid-county Memo &raquo; 82nd Avenue looks at life after 82nd Avenue of Roses Implementation Plan Comments Feed" href="https://midcountymemo.com/2017/10/82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan/feed/" />
<!-- This site is powered by Shareaholic - https://shareaholic.com -->
<script type='text/javascript' data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/midcountymemo.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","share_counts_url":"https:\/\/midcountymemo.com\/wp-admin\/admin-ajax.php?action=shareaholic_share_counts_api"},"url_components":{"year":"2017","monthnum":"10","day":"28","post_id":"3648","postname":"82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan","author":"jack-rushall"}};
  //]]>
</script>
<script type='text/javascript' data-cfasync='false'
        src='//apps.shareaholic.com/assets/pub/shareaholic.js'
        data-shr-siteid='5d12382e076ca5177a8e6ddc58156c73' async='async' >
</script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='Mid-county Memo' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://midcountymemo.com/2017/10/82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan/' />
<meta name='shareaholic:keywords' content='82nd avenue of roses implementation plan, 82nd avenue., east portland, oregon department of transportation, terra lingley, 82nd avenue, 2017, october, post' />
<meta name='shareaholic:article_published_time' content='2017-10-28T12:42:49+00:00' />
<meta name='shareaholic:article_modified_time' content='2017-10-05T22:41:23+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Jack Rushall' />
<meta name='shareaholic:site_id' content='5d12382e076ca5177a8e6ddc58156c73' />
<meta name='shareaholic:wp_version' content='8.5.1' />

<!-- Shareaholic Content Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/midcountymemo.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Trim v.2.3.3" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='et-shortcodes-css-css'  href='https://midcountymemo.com/wp-content/themes/Trim/epanel/shortcodes/css/shortcodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='et-shortcodes-responsive-css-css'  href='https://midcountymemo.com/wp-content/themes/Trim/epanel/shortcodes/css/shortcodes_responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='https://midcountymemo.com/wp-content/themes/Trim/epanel/page_templates/js/fancybox/jquery.fancybox-1.3.4.css' type='text/css' media='screen' />
<link rel='stylesheet' id='et_page_templates-css'  href='https://midcountymemo.com/wp-content/themes/Trim/epanel/page_templates/page_templates.css' type='text/css' media='screen' />
<script type='text/javascript' src='https://midcountymemo.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='https://api.w.org/' href='https://midcountymemo.com/wp-json/' />
<link rel='shortlink' href='https://midcountymemo.com/?p=3648' />
<link rel="alternate" type="application/json+oembed" href="https://midcountymemo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmidcountymemo.com%2F2017%2F10%2F82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://midcountymemo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmidcountymemo.com%2F2017%2F10%2F82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan%2F&#038;format=xml" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" /><link id='droid_sans' href='http://fonts.googleapis.com/css?family=Droid+Sans' rel='stylesheet' type='text/css' /><style type='text/css'>body { font-family: 'Droid Sans', Arial, sans-serif !important;  }</style><style type='text/css'>body {  }</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #519eba; }
</style>
<link rel="amphtml" href="https://midcountymemo.com/2017/10/82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan/amp/" /><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-3589332-1', 'auto');
  ga('send', 'pageview');

</script><style type="text/css" id="et-custom-css">
#search-form { display: none; }

#top-area {padding: 22px 49px 144px 58px;}
.blog .featured_box, .archive .featured_box { width: 200px; height: auto; float: left; margin-right: 8px; }
#top-area {padding: 22px 49px 144px 58px;}
.blog .featured_box, .archive .featured_box { width: 100%; height: auto; float: left; margin-right: 8px; }
#top-area, #featured_controls, #featured-controllers, #services, #quote, #home-sections, #menu { border-bottom: 1px solid #519eba; }
#search-form, #commentform input[type="text"], #commentform textarea, blockquote { border:1px solid #519eba; }
#featured-controllers li, #comment-wrap:before, #respond:before { border-top:1px solid #519eba; }
#home-sections:before, #main_content:before { border-left: 1px dashed #519eba; }
#menu .nav li, #featured-controllers li, .footer-widget { border-right: 1px dashed #519eba; }
#mobile_nav { border: 1px dashed #519eba; }
#menu .nav a, ul#mobile_menu a, p.meta, p.meta a { color: #519eba; }
#breadcrumbs span, #breadcrumbs a { color: #519eba; }
#main_content:before { left: 619px; }
@media only screen and ( min-width: 768px ) and ( max-width: 960px ) {
#main_content:before { left: 492px; }
}
@media only screen and ( max-width: 767px ) {
#top-area { padding-bottom: 0; }
}

ul#mobile_menu a {
color: #fff !important;
}

.featured_box img { width: 481px!important; height: auto!important; }
#content { font-size: 18px; }
</style></head>
<body class="post-template-default single single-post postid-3648 single-format-standard custom-background unknown et_includes_sidebar">
	<div id="container">
		<div id="wrapper">
			<header id="main-header" class="clearfix">
				<div id="top-area">
										<a href="https://midcountymemo.com/">
												<img src="https://midcountymemo.com/wp-content/uploads/2017/10/oct2017_main_hdr.jpg" alt="Mid-county Memo" id="logo"/>
					</a>
					<div id="search-form">
						<form method="get" id="searchform" action="https://midcountymemo.com//">
							<input type="text" value="Search..." name="s" id="searchinput" />
							<input type="image" alt="Submit" src="https://midcountymemo.com/wp-content/themes/Trim/images/search_btn.png" id="searchsubmit" />
						</form>
					</div> <!-- end #search-form -->
				</div> <!-- end #top-area -->

				<div id="menu" class="clearfix">
					<a href="#" id="mobile_nav" class="closed">Navigation Menu</a>
					<nav id="main-menu">
						<ul id="menu-full-menu" class="nav"><li id="menu-item-32" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-32"><a href="https://midcountymemo.com/">Home</a></li>
<li id="menu-item-196" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-196"><a>About</a>
<ul  class="sub-menu">
	<li id="menu-item-33" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33"><a href="https://midcountymemo.com/about-the-memo/">Our Paper</a></li>
	<li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://midcountymemo.com/staff/">Our Staff</a></li>
</ul>
</li>
<li id="menu-item-164" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164"><a>Departments</a>
<ul  class="sub-menu">
	<li id="menu-item-81" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://midcountymemo.com/calendar/">Calendar</a></li>
	<li id="menu-item-83" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="https://midcountymemo.com/memo-pad/">Memo Pad</a></li>
	<li id="menu-item-89" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89"><a href="https://midcountymemo.com/business-memos/">Business Memos</a></li>
	<li id="menu-item-90" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90"><a href="https://midcountymemo.com/letters/">Letters</a></li>
	<li id="menu-item-82" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a href="https://midcountymemo.com/meals-on-wheels/">Meals on Wheels</a></li>
	<li id="menu-item-161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-161"><a href="https://midcountymemo.com/mid-county-restaurant-ratings/">Mid-county Restaurant Ratings</a></li>
	<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://midcountymemo.com/lottery/">Oregon Lottery in Mid-county</a></li>
	<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://midcountymemo.com/parkrose-athletic/">Parkrose Athletic Schedule</a></li>
</ul>
</li>
<li id="menu-item-197" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-197"><a>Advertising</a>
<ul  class="sub-menu">
	<li id="menu-item-34" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34"><a href="https://midcountymemo.com/advertise/">Print &#038; Web Rates</a></li>
	<li id="menu-item-36" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36"><a href="https://midcountymemo.com/coverage-areas/">Coverage Areas</a></li>
</ul>
</li>
<li id="menu-item-191" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-191"><a href="/about/">Contact</a></li>
</ul>					</nav>

					<div id="social-icons">
						<a href='https://twitter.com/midcountymemo' target='_blank'><img alt='Twitter' src='https://midcountymemo.com/wp-content/themes/Trim/images/twitter.png' /></a><a href='/feed/' target='_blank'><img alt='Rss' src='https://midcountymemo.com/wp-content/themes/Trim/images/rss.png' /></a><a href='https://www.facebook.com/midcountymemo' target='_blank'><img alt='Facebook' src='https://midcountymemo.com/wp-content/themes/Trim/images/facebook.png' /></a>					</div> <!-- end #social-icons -->
				</div> <!-- end #menu -->
			</header> <!-- end #main-header -->

			<div id="content">
<div id="main_content" class="clearfix">
	<div id="left_area">
		<div id="breadcrumbs">
					<a href="https://midcountymemo.com/">Home</a> <span class="raquo">&raquo;</span>

									<a href="https://midcountymemo.com/2017/">2017</a> <span class="raquo">&raquo;</span> 82nd Avenue looks at life after 82nd Avenue of Roses Implementation Plan					</div> <!-- end #breadcrumbs -->			
	<article class="entry post clearfix">
					<span class="post-meta">Sat<span>28</span></span>
		
		<h1 class="main_title">82nd Avenue looks at life after 82nd Avenue of Roses Implementation Plan</h1>

		<p class="meta">Posted  by <a href="https://midcountymemo.com/author/jack-rushall/" title="Posts by Jack Rushall" rel="author">Jack Rushall</a> on Oct 28, 2017</p>
		<div class="post-content clearfix">
						
			<div class="entry_content">
				<div class='shareaholic-canvas' data-app-id='7898751' data-app-id-name='post_above_content' data-app='share_buttons' data-title='82nd Avenue looks at life after 82nd Avenue of Roses Implementation Plan' data-link='https://midcountymemo.com/2017/10/82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan/' data-summary=''></div><p>82nd Avenue is the spine that connects east and west Portland. The 82nd Avenue of Roses Implementation Plan, as the Mid-county Memo previously reported, is the Oregon Department of Transportation’s (ODOT) rigorous series of projects designed to work out kinks in the road.</p>
<p>The plan means to identify four priority areas and safety projects that can be funded in the short-term (5 to 10 years) to improve this invaluable road even past the plan’s conclusion next year. It’s about to enter its third and final stage.</p>
<p>So far, there have been established improvements, like the repaving of roads and sidewalks, as well as the installation of sidewalk curb ramps.</p>
<p>“We’re not looking at big things like adding bike lanes or purchasing more land; they’re very targeted things,” explains Terra Lingley, the project manager of the 82nd Avenue of Roses Implementation Plan from ODOT. “We targeted a couple specific areas and went through scenarios.”</p>
<p>Scenario one revolves around mostly sidewalk updates, closing unused driveways—or driveways deemed too wide—that make pedestrians feel unsafe. Scenario two includes these updates, as well as additional crossings and getting an additional crossing at Clackamas County, where there are a couple areas without sidewalks. In executing these sidewalks’ construction, consider the sidewalks by Portland Community College on 82nd Avenue as an example.</p>
<p>The seventh meeting of the community advisory committee, made up of a diverse group of residents, cyclists and transit users, as well as interested businesses, was held following Labor Day on Sept. 6. There, ODOT discussed memos, analysis and ground truth on different matters and possibilities, with the committee adding input. There is to be only one more committee meeting on behalf of the 82nd Avenue of Roses Implementation Plan, likely to be held later this fall. However, there is talk of funding further small-scale projects even after the plan’s conclusion.</p>
<p>“We don’t have any funding to implement the plan,” says Lingley. “So we looked at three levels of funding: businesses, as usual, or investments of $1 million or less. The second scenario looks at a bigger project and going after a grant (between $1 million and $10 million), and the third is [asking the question]: What if the legislature spends money on us? This could be anything over $10 million. We are currently writing the plan and are going to go into our next phase of public involvement with an open house in mid-to-late October.”</p>
<p>Below are a couple additional updates on a few specific summertime projects that the Mid-county Memo had previously reported on.</p>
<p><b>Southeast 82nd Avenue: Waterline Abandonment Project</b><br />
The Waterline Abandonment Project was a $600,000 Clackamas River Water maintenance procedure that removed sole older and underlined water lines and system hydraulics. Specifically, it removed some 2-, 4- and 6-inch lines and reconnected a 10-inch line. The improved hydraulics were essential considering fire flows. It finished in early July in preparation for some ODOT paving projects along 82nd Avenue.</p>
<p>“We were pleased to be able to finish our project on time and on budget prior to the ODOT project. We looked at it as an opportunity project to coordinate with ODOT to do some work that would help address some needs we had,” says Todd Heidgerken, general manager at Clackamas River Water.</p>
<p><b>Lindy Street to Mt. Scott Creek Bridge and Safety Project</b><br />
In its second phase, this $850,000, three-phase project will ultimately see improvements along the portion of Southeast 82nd Avenue that services the Clackamas Regional Center in the form of sidewalk ramps at the intersection between Southeast King Road and the Mount Scott Creek Bridge. According to Lingley, it’s still on time.</p>
<p>“We’re looking to add some more money to our statewide transportation improvement program from 2019 to 2021 for Lindy to Foster. It’s an $8 million project for [Americans with Disabilities Act] ramps and railing,” Lingley added.</p>
<div class='shareaholic-canvas' data-app-id='7898747' data-app-id-name='post_below_content' data-app='share_buttons' data-title='82nd Avenue looks at life after 82nd Avenue of Roses Implementation Plan' data-link='https://midcountymemo.com/2017/10/82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan/' data-summary=''></div>											</div> <!-- end .entry_content -->
		</div> <!-- end .post-content -->
	</article> <!-- end .post -->

	
	
	<!-- You can start editing here. -->

<section id="comment-wrap">
		   <div id="comment-section" class="nocomments">
		  			 <!-- If comments are open, but there are no comments. -->

		  	   </div>
					<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Post a Reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/10/82nd-avenue-looks-life-82nd-avenue-roses-implementation-plan/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://midcountymemo.com/wp-comments-post.php?wpe-comment-post=memosite" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='3648' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
		
</section>	</div> <!-- end #left_area -->

		<div id="sidebar">
		<div id="archives-2" class="widget widget_archive"><h4 class="widget_title">Previous Issues</h4>		<label class="screen-reader-text" for="archives-dropdown-2">Previous Issues</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://midcountymemo.com/2017/10/'> October 2017 </option>
	<option value='https://midcountymemo.com/2017/09/'> September 2017 </option>
	<option value='https://midcountymemo.com/2017/08/'> August 2017 </option>
	<option value='https://midcountymemo.com/2017/07/'> July 2017 </option>
	<option value='https://midcountymemo.com/2017/06/'> June 2017 </option>
	<option value='https://midcountymemo.com/2017/05/'> May 2017 </option>
	<option value='https://midcountymemo.com/2017/04/'> April 2017 </option>
	<option value='https://midcountymemo.com/2017/03/'> March 2017 </option>
	<option value='https://midcountymemo.com/2017/02/'> February 2017 </option>
	<option value='https://midcountymemo.com/2017/01/'> January 2017 </option>
	<option value='https://midcountymemo.com/2016/12/'> December 2016 </option>
	<option value='https://midcountymemo.com/2016/11/'> November 2016 </option>
	<option value='https://midcountymemo.com/2016/10/'> October 2016 </option>
	<option value='https://midcountymemo.com/2016/09/'> September 2016 </option>
	<option value='https://midcountymemo.com/2016/08/'> August 2016 </option>
	<option value='https://midcountymemo.com/2016/07/'> July 2016 </option>
	<option value='https://midcountymemo.com/2016/06/'> June 2016 </option>
	<option value='https://midcountymemo.com/2016/05/'> May 2016 </option>
	<option value='https://midcountymemo.com/2016/04/'> April 2016 </option>
	<option value='https://midcountymemo.com/2016/03/'> March 2016 </option>
	<option value='https://midcountymemo.com/2016/02/'> February 2016 </option>
	<option value='https://midcountymemo.com/2016/01/'> January 2016 </option>
	<option value='https://midcountymemo.com/2015/12/'> December 2015 </option>
	<option value='https://midcountymemo.com/2015/11/'> November 2015 </option>
	<option value='https://midcountymemo.com/2015/10/'> October 2015 </option>
	<option value='https://midcountymemo.com/2015/09/'> September 2015 </option>
	<option value='https://midcountymemo.com/2015/08/'> August 2015 </option>
	<option value='https://midcountymemo.com/2015/07/'> July 2015 </option>
	<option value='https://midcountymemo.com/2015/06/'> June 2015 </option>
	<option value='https://midcountymemo.com/2015/05/'> May 2015 </option>
	<option value='https://midcountymemo.com/2015/04/'> April 2015 </option>
	<option value='https://midcountymemo.com/2015/03/'> March 2015 </option>
	<option value='https://midcountymemo.com/2015/02/'> February 2015 </option>
	<option value='https://midcountymemo.com/2015/01/'> January 2015 </option>
	<option value='https://midcountymemo.com/2014/12/'> December 2014 </option>
	<option value='https://midcountymemo.com/2014/11/'> November 2014 </option>
	<option value='https://midcountymemo.com/2014/10/'> October 2014 </option>
	<option value='https://midcountymemo.com/2014/09/'> September 2014 </option>
	<option value='https://midcountymemo.com/2014/08/'> August 2014 </option>

		</select>
		</div> <!-- end .widget --><div id="text-10" class="widget widget_text"><h4 class="widget_title">Newspaper Morgue </h4>			<div class="textwidget"><a href=" https://midcountymemo.com/archives/">August 2001 to August 2014</a></div>
		</div> <!-- end .widget --><div id="text-11" class="widget widget_text"><h4 class="widget_title"> </h4>			<div class="textwidget"><div align="center"><a href="http://www.oregonlive.com/onn" target="_blank" rel="noopener"><img src="https://midcountymemo.com/memlog/wp-content/uploads/ONN_logo_text_186.jpg" alt="Oregonian News Network" border="0" /></a><a href="http://www.spj.org/" target="_blank" rel="noopener"><img src="/wp-content/uploads/download-1-e1412035243262.jpg" alt="Oregonian News Network" border="0" /></a></p>
</div>
</div>
		</div> <!-- end .widget --><div id="text-5" class="widget widget_text"><h4 class="widget_title"> </h4>			<div class="textwidget"><div align="center">
<a href="http://www.cityhomeimprovementinc.com/" target="_blank"><img src="https://midcountymemo.com/images/city_home_ani_new.gif" alt="City Home Improvement" /></a>

<a href="http://www.tirefactory.com/parkrose" target="_blank"><img src="https://midcountymemo.com/wp-content/uploads/83587_Browns699_2016.05.06_Mid-County-Memo-Banner-Ad_120x240.jpg" alt="Brown Tire Factory" /></a>

<a href="http://www.eatatelmers.com/" target="_blank"><img src="https://midcountymemo.com/images/elmers_ani_new.gif" alt="Elmer's Restaurant" /></a> <br>

<a href="http://www.fortknoxmini-storage.com" target="_blank"><img src="https://midcountymemo.com/images/fort_knox_banner.jpg" alt="Fort Knox Mini Storage" /></a> <br>

<a href="http://www.gosolarparkrose.com" target="_blank"><img src="https://midcountymemo.com/wp-content/uploads/2017/03/SES_web_ad.jpg" alt="Solar Energy Solutions" /></a> <br>


</div></div>
		</div> <!-- end .widget --><div id="search-3" class="widget widget_search"><h4 class="widget_title"> </h4><form role="search" method="get" id="searchform" class="searchform" action="https://midcountymemo.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div> <!-- end .widget --><div id="text-8" class="widget widget_text"><h4 class="widget_title"> </h4>			<div class="textwidget"><div align="center">
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fmidcountymemo&amp;width=235&amp;height=258&amp;colorscheme=light&amp;show_faces=true&amp;border_color&amp;stream=false&amp;header=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:235px; height:258px;" allowTransparency="true"></iframe>
</div>
<br>
<a href="/wp-admin" target="_blank"  rel="nofollow">Editor log-In</a></div>
		</div> <!-- end .widget -->	</div> <!-- end #sidebar -->
</div> <!-- end #main_content -->

				<div id="footer">

					<div id="footer-widgets" class="clearfix">

						<div class="footer-widget"><div id="rss-14" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.publicalerts.org/rss.xml' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.publicalerts.org/latest-alerts?' target='_blank' title=''>Public Alerts</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://twitter.com/TripCheckPDX/status/924534431896936448' target='_blank' title='I-205, from I-5 to Stafford Rd, Delay 20min-2hrs, Road work has the right lanes closed NB from the I-5 interchang... https://t.co/igz3zwTRXp'>I-205, from I-5 to Stafford Rd, Delay 20min-2hrs, Road work has the right lanes closed NB from the I-5 interchang... https://t.co/igz3zwTRXp</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://twitter.com/NWSPortland/status/924416495639318528' target='_blank' title='The last time PDX airport had 3 straight 70 deg days for the period Oct 26-28 was back in 2003. So far 71 today. #orwx #pdxtst'>The last time PDX airport had 3 straight 70 deg days for the period Oct 26-28 was back in 2003. So far 71 today. #orwx #pdxtst</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://twitter.com/TripCheckPDX/status/924357768831680512' target='_blank' title='I-5, @ Victory Blvd, Delay 20min-2hrs, A crash has occurred SB @ Columbia, left and center lanes closed.... https://t.co/bjLhnrLLFV'>I-5, @ Victory Blvd, Delay 20min-2hrs, A crash has occurred SB @ Columbia, left and center lanes closed.... https://t.co/bjLhnrLLFV</a></li></ul></div> <!-- end .f_widget --><div id="rss-10" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.google.com/calendar/feeds/parkrose.k12.or.us_15j6km0ui85kplddm9mqadgi8c%40group.calendar.google.com/public/basic' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='' target='_blank' title=''>Parkrose School District</a></h4></div> <!-- end .f_widget --><div id="rss-3" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.ddouglas.k12.or.us/feed/' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='https://www.ddouglas.k12.or.us' target='_blank' title='Learning Today for Living Tomorrow'>David Douglas School District</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://www.ddouglas.k12.or.us/2017/10/ddsd-immunization-data/' target='_blank' title='The State of Oregon requires schools and districts to share immunization and exemption rates with families twice per year. The latest information is available in your school’s office, on the District’s website under the ‘Parents’ menu (Immunization and Medication Requirements) and during parent-teacher conferences. Visit the Immunization and Medication Requirements page to view...  Read more » The post DDSD Immunization Data appeared first on David Douglas School District. '>DDSD Immunization Data</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://www.ddouglas.k12.or.us/2017/10/culturally-specific-family-engagement-workshop-2/' target='_blank' title='The David Douglas School District through a generous East Portland Action Plan Civic Engagement Grant and partnership will hold culturally specific family engagement events with high culturally diverse populations. Our goal is to provide time and space opportunities for our families to attend events which are intended to build and improve relationships...  Read more » The post Culturally Specific Family Engagement – Workshop #2 appeared first on David Douglas School District. '>Culturally Specific Family Engagement – Workshop #2</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://www.ddouglas.k12.or.us/2017/10/family-survey-coming/' target='_blank' title='The District wants to hear from parents and guardians about how we are doing and how we can improve the educational outcome for your students. During the month of November, we will offer our parents the opportunity to take a survey. The survey is anonymous, but the results will help us focus...  Read more » The post Family Survey Coming appeared first on David Douglas School District. '>Family Survey Coming</a></li></ul></div> <!-- end .f_widget --><div id="rss-15" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.trimet.org/rss/index.htm#alerts' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='' target='_blank' title=''>TriMet Service Alerts</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --><div id="rss-8" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://feeds.feedburner.com/rsd7?' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='' target='_blank' title=''>Reynolds School District</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --><div id="rss-18" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=49305' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=49305' target='_blank' title=''>Portland Parks &#038; Recreation</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --></div><div class="footer-widget"><div id="rss-21" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=36652' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=36652' target='_blank' title='Downtown, Arlington Heights, Forest Park, Goosehollow, Hillside, Linnton, Northwest District, Northwest Heights, Northwest Industrial, Pearl District and Sylvan-Highlands '>City Land Use Notices, Hearings and Decisions</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=46575&#038;a=660988' target='_blank' title='PDF Document, 2,341kbCategory: Neighbors West/Northwest Decisions'>Sylvan-Highlands &amp; SWHRL | 10-27-07 | 1320 SW Highland Pkwy | Environmental Review | LU 17-228601 EN</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=46579&#038;a=660986' target='_blank' title='PDF Document, 2,341kbCategory: Southwest Neighborhoods, Inc. Decisions'>Sylvan-Highlands &amp; SWHRL | 10-27-07 | 1320 SW Highland Pkwy | Environmental Review | LU 17-228601 EN</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=46579&#038;a=660985' target='_blank' title='PDF Document, 1,501kbCategory: Southwest Neighborhoods, Inc. Decisions'>Multnomah | 10-27-07 | 3825 SW Canby St | Land Division - Subdivision | LU 16-291559 LDS</a></li></ul></div> <!-- end .f_widget --><div id="rss-20" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=61875' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=61875' target='_blank' title='Application materials for new licensees'>City of Portland New Liquor License Applications</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=61875&#038;a=630656' target='_blank' title='PDF Document, 955kbCategory: New Liquor License Applications'>Liquor Licensing Forms and Checklist</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=61875&#038;a=580926' target='_blank' title='This link only provides the form to fill our personal history of each applicant. PDF Document, 213kbCategory: New Liquor License Applications'>Personal History Form</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=61875&#038;a=580925' target='_blank' title='This link only provides the form to provide outlet information. PDF Document, 332kbCategory: New Liquor License Applications'>Outlet Information Form</a></li></ul></div> <!-- end .f_widget --><div id="rss-12" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=25783' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=25783' target='_blank' title='Southeast Uplift Neighborhood Coalition'>City of Portland</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=69047&#038;a=661059' target='_blank' title='Nightmare on Stark Street and Purgatory Prom 10/28 PDF Document, 375kbCategory: Inner Southeast Portland (SEUL)'>518 SE 76th Ave</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=69049&#038;a=661058' target='_blank' title='Construction - Paving / restoration of NW 4th Avenue 10/26 PDF Document, 561kbCategory: Northwest and Inner Southwest Portland (NWNW)'>ROW - NW 4th Ave between NW Couch and W Burnside</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=58190&#038;a=661057' target='_blank' title='Members will monitor Comprehensive Plan-related public engagement efforts on a new Community Involvement Committee.'>Community members sought for new advisory committee for land use plans</a></li></ul></div> <!-- end .f_widget --><div id="rss-11" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=29795' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=29795' target='_blank' title=''>Portland Police Bureau</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --><div id="rss-17" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.flashalert.net/news.html?id=549#news78560' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='' target='_blank' title=''>Portland Fire &#038; Rescue</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --></div><div class="footer-widget last"><div id="rss-16" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.flashalert.net/news.html?id=1276' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='' target='_blank' title=''>Multnomah County Sheriff&#8217;s Office</a></h4><ul><li>An error has occurred; the feed is probably down. Try again later.</li></ul></div> <!-- end .f_widget --><div id="rss-13" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://www.portlandoregon.gov/rss.cfm?c=48714' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=48714' target='_blank' title='Woodland Park'>East Portland Neighborhood Offices</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=48684&#038;a=491293' target='_blank' title='Find information such as area parks, schools, planned projects, zoning information, aerial maps and much more on PortlandMaps.com'>PortlandMaps.com link for Woodland Park neighborhood</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=48684&#038;a=491291' target='_blank' title='Link to Bureau of Planning and Sustainability&#039;s District Planning Program'>District Liaison Planning Program</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.portlandoregon.gov/index.cfm?c=48684&#038;a=491289' target='_blank' title='Link to Prosper Portland&#039;s Website with information about geographically based development programs'>Prosper Portland&#039;s Urban Renewal and Development Programs</a></li></ul></div> <!-- end .f_widget --><div id="rss-9" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='https://eastportlandchamberofcommerce.com/Month-at-a-Glance/RSS' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='https://eastportlandchamberofcommerce.com/Month-at-a-Glance' target='_blank' title='East Portland Chamber of Commerce upcoming events'>East Portland Chamber of Commerce</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://eastportlandchamberofcommerce.com/event-2697507' target='_blank' title='Community Preservation Partners will be hosting an Awards Ceremony &amp; Ribbon Cutting October 30th at 4:00pm. Please join this new East Portland Chamber member for an afternoon of fun! The Awards Ceremony starts at 4:00pm, followed immediately by a Ribbon Cutting and then a reception at 5:30pm.   CPP was established in 2004 to promote the preservation of low-income housing and to assist existing owners and/or general partners with recapitalizing and revitalizing their affordable housing portfolios.  Since then, it has successfully acquired, developed and rehabilitated more than 5,000 affordable multi-family and senior housing units across the nation.  CPP is more than a consultant or an investor. We are a true partner in every sense. CPP helps enrich the local community by joining forces with leading nonprofits and strategically partnering to provide essential social services to residents.  www.cpp-housing.com'>Community Preservation Partners Ribbon Cutting (October 30, 2017)</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://eastportlandchamberofcommerce.com/event-2668915' target='_blank' title='Calling all adventurous taste buds! The East Portland Chamber of Commerce Diversity Committee invites all Chamber members and their guests to join us on Tuesday, October 31st for a Tasty Tuesday lunch at Mercado at 12:00 noon. We will be meeting at a different restaurant on the last Tuesday of every month.  This is not a committee meeting and there is no agenda for the lunch, we simply want to patronize local Eastside minority owned restaurants for lunch and support their businesses.           '>Tasty Tuesday 10-31-17 (October 31, 2017)</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='https://eastportlandchamberofcommerce.com/event-2590716' target='_blank' title='Jason Stein - Facebook Live for Small Business Owners  Is Facebook a huge waste of time or an amazing marketing opportunity?  The answer is yes depending on your business strategies. There are now over 1.5 billion users on Facebook and most of your customers use it on a daily basis.  Come join Jason Stein and learn 3 tips on how you can get started with Facebook LIVE and grow your customer base without spending tons of money.   Jason Stein coaches successful entrepreneurs &amp; small business owners looking for support and accountability in achieving healthy profits, healthy relationships, and healthy impact. www.jasonstein.com  Coffee and breakfast goodies will be provided by CherryWood Village.  Refreshments and facility sponsored by:'>Education AM Nov 1st (November 01, 2017)</a></li></ul></div> <!-- end .f_widget --><div id="rss-7" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://parkrosebusiness.org/feed/' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://parkrosebusiness.org' target='_blank' title='PBA provides a unified voice to City of Portland officials on behalf of the Parkrose business community'>Parkrose Business Association</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://parkrosebusiness.org/2017/02/28/crime-reporting-tool-kit-2/' title='The Parkrose Business Association is committed to creating a safe environment for our local businesses. Download our crime reporting tool kit to find the best resource to report vandalism, theft, or other suspicious activity. Download: Parkrose Crime Reporting Tool KitRead More'>Crime Reporting Tool Kit</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://parkrosebusiness.org/2015/11/25/holiday/' title='Bring in the Parkrose Business Association coupon from The Grotto’s Festival of Lights brochure to redeem holiday deals and discounts at the participating businesses below. 2015 Holiday Coupons:   Get your home ready for the holidays! Baskets and Bouquets by Sharon (15766 Ne Rose Pkwy) Get the perfect holiday centerpiece.Read More'>2015 Grotto Holiday Coupons</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://parkrosebusiness.org/2015/05/12/know-your-neighbor-portland-disposal/' title='Portland Disposal and Recycling Ray Salvi – owner   What does your business do/sell?   We do disposal and recycling in the City of Portland. We have a contract with the City that picks up the majority of the residences in Parkrose. We also offer commercial services.   Did youRead More'>Know Your Neighbor – Portland Disposal</a></li></ul></div> <!-- end .f_widget --><div id="rss-19" class="f_widget tabbed_rss"><h4 class="widgettitle"><a class='rsswidget' href='http://www.oregonmetro.gov/news.xml' target='_blank' title='Syndicate this content'><img style='background:orange;color:white;border:none;' width='14' height='14' src='https://midcountymemo.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.oregonmetro.gov/news/archive?&#038;&#038;created%5Bvalue%5D&#038;councilor=&#038;project=All&#038;search_keys=&#038;sort_by=created&#038;sort_order=DESC' target='_blank' title=''>Metro</a></h4><ul><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.oregonmetro.gov/news/read-fall-2017-issue-our-big-backyard' target='_blank' title='         Enjoy nature photos taken by young people who live in outer southeast Portland, find tips to turn your yard into winter habitat for native wildlife -- and more. Read the fall issue of Our Big Backyard, Metro&#039;s quarterly parks and nature magazine.   '>Read the fall 2017 issue of Our Big Backyard</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.oregonmetro.gov/news/public-notice-opportunity-comment-pending-amendment-metropolitan-transportation-improvement-7' target='_blank' title='         Metro is in receipt of Proposed MTIP Formal Amendments. To share your views, comment by 5 p.m. Nov. 22, 2017. A final notice will not be published.   '>Public notice: Opportunity to comment on pending amendment to the Metropolitan Transportation Improvement Plan</a></li><li style="padding-bottom: 4px;"><a class='rsswidget' href='http://www.oregonmetro.gov/news/metro-departments-get-community-feedback-equity-action-plans' target='_blank' title='By Cristina RojasBylined articles are written by Metro staff and do not necessarily represent the opinions of Metro or the Metro Council. Learn more          The agency-wide Strategic Plan to Advance Racial Equity, Diversity and Inclusion calls for each department and venue to develop its own five-year action plan   '>Metro departments get community feedback on equity action plans</a></li></ul></div> <!-- end .f_widget --></div>
					</div> <!-- end #footer-widgets -->

				</div> <!-- end #footer -->

			</div> <!-- end #content -->

		</div> <!-- end #wrapper -->



		<p id="copyright">Designed by <a href="http://www.getwpress.com" target="_blank" title="Premium WordPress Themes">GetWPress</a> | Powered by <a href="http://www.wordpress.org" target="_blank">WordPress</a></p>
	</div> <!-- end #container -->



	<!-- Facebook Pixel Code -->



<!-- ConnectRetarget PowerPixel -->
<script>
var CRConfig = {
    'pixel_prefix':'searchcommanderconnectio',
    'init_fb':true,
    'fb_pixel_id':'313786535445179'
};
</script>
<script src='//connectio.s3.amazonaws.com/connect-retarget.js?v=1.1'></script>
<noscript><img height='1' width='1' style='display:none' src='https://www.facebook.com/tr?id=313786535445179&ev=PageView&noscript=1' /></noscript>
<!-- End ConnectRetarget PowerPixel -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '382320112160402'); // Insert your pixel ID here.
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=382320112160402&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code --><script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/js/superfish.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/js/jquery.easing.1.3.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/js/jquery.flexslider-min.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/js/custom.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/epanel/page_templates/js/fancybox/jquery.fancybox-1.3.4.pack.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var et_ptemplates_strings = {"captcha":"Captcha","fill":"Fill","field":"field","invalid":"Invalid email"};
/* ]]> */
</script>
<script type='text/javascript' src='https://midcountymemo.com/wp-content/themes/Trim/epanel/page_templates/js/et-ptemplates-frontend.js'></script>
<script type='text/javascript' src='https://midcountymemo.com/wp-includes/js/wp-embed.min.js'></script>

</body>

</html>

